FAQs: Other

Find answers to your questions about Western Schools.

What device hardware or software do I need to take your courses?

You must have a current version of your preferred internet browser in order to take the courses. Older versions are no longer supported by their own vendors or by most websites.

To open PDF courses, you need a PDF reader like Adobe Reader. To open pretests, exams, attestations and evaluations, you need Adobe Flash Player. These are software products from Adobe, available at www.adobe.com for free download.

Still can't find your answer?

If you can't find what you're looking for, please contact us.

Call Us icon

Call us: 800.618.1670

Speak to a customer service representative.

Weekdays: 8 a.m. - 8 p.m. ET

Get in touch icon

Send us a note

Email us and we'll get back to you within 24 hours

Email Us